SmartNAVI

SmartNAVI 1.6

Free
This version of SmartNAVI requires NS4600 SR1.1 firmware.

This version of SmartNAVI requires NS4600 SR1.1 firmware (V02.01.0000.12) or DS4600 SR1 firmware (v2.05). Please note that SmartNAVI 2.0 DOES NOT support NS4300N and NS2300N and former models.
See NS4600/DS4600 Release Notes for more detail.
SmartNAVI for Mac OS X 10.4, 10.5 and 10.6.

Info updated on: